Hey Unbekannter!

 Diese Seite ist eine Fundgrube für alles rund um Animal Crossing. Wenn du bei uns mitmachen willst, melde dich an!

Ereignisse im November
Animal Crossing: New Horizons
01.09. – 10.12.
Baumfrucht-Saison
24.10. – 22.11.
Skorpion-Splitter
01. – 30.11.
Pilz-Saison
16. – 25.11.
Herbstblätter-Saison
26.11.
Schlemmfest
25.08. – 30.11.
Frühlingsbambus-Saison (Südhalbkugel)
23.11. – 21.12.
Schütze-Splitter

Neuestes Foto

Auf der Suche nach Anleitungen
Von Luna

QR-Codes erstellen!

[SW] NAT-Typ A freischalten (Online-Spiel Verbindungsprobleme beheben)

Solltest du Probleme beim Besuchen von anderen Insel über Nintendo Switch Online (oder anderen Multiplayer Spielen) haben, schau dir die folgende Anleitung an.

Vorab

Mach zuerst einen Verbindungstest in deiner Switch (Systemeinstellungen > Internet > Verbindungstest). Wird dort der NAT-Typ A angezeigt, liegt das Problem wahrscheinlich woanders. Wird NAT-Typ B,C oder D aufgeführt lohnt es sich die folgenden Tipps auszuprobieren.

Prüfe auch, ob dein Internetanschluss das Problem ist. Die Switch kann nur mit dem alten IPv4 Protokoll umgehen. Die Internetanbieter setzen aber heutzutage meist auf das neuere IPv6. Prüfe in deinem Router, ob du eine richtige IPv4-Verbindung oder nur sogenanntes "DS-Lite" hast:

Wenn du eine Fritz!Box wie in diesem Beispiel hast, gehe einfach auf http://fritz.box oder http://192.168.178.1 .

Hast du einen DS-Lite Anschluss, hilft dir die folgende Anleitung wahrscheinlich nicht weiter. Versuche den Kundenservice deines Internetanbieters zu kontaktieren und frage nach einer öffentlichen IPv4-Adresse. Viele stellen diese auf Anfrage kostenfrei zur Verfügung.

Anleitung mit der Fritz!Box

Solltest du eine Fritz!Box als Router verwenden, solltest du dieser Anleitung folgen. Falls nicht und dir die Anleitung weiter unten nicht geholfen hat, kannst du auch versuchen die hier beschriebenen Punkte umzusetzen.

  1. Rufe die Router Einstellungen unter http://fritz.box oder http://192.168.178.1 auf.

  2. Melde dich an (Kennwörter liegen meist der Verpackung bei oder befinden sich unten am Gehäuse der Fritz!Box).

  3. Wähle im Menü Internet > Freigaben und bleibe im Tab Portfreigaben.

  4. Klicke auf "Gerät für Freigaben hinzufügen".

  5. Als nächstes musst du unter Gerät die Switch auswählen. Kannst du sie nicht in der Liste ausfindig machen, so schau dir in den Switch Systemeinstellungen unter Internet die IP-Adresse an. Wähle dann in der Liste den Eintrag mit der entsprechenden IP-Adresse z.B. PC-192-168-178-31 .

  6. Setze nun das Häkchen bei IPv4-Einstellungen > Dieses Gerät komplett für den Internetzugriff über IPv4 freigeben (Exposed Host).
    Hinweis: Dadurch wird die Switch nach außen komplett sichtbar gemacht. Du solltest diese Einstellungen aus Sicherheitsgründen nur solange aktiviert lassen, wie du auch das Online Spiel nutzt. Danach solltest du sie wieder deaktivieren.

  7. Klicke nun auf OK und auf Übernehmen.

  8. Es ist alles eingestellt. Führe nun einen Verbindungstest auf der Switch aus. Du solltest jetzt einen besseren NAT-Typ erhalten.

Anleitung mit anderen Routern

Diese Anleitung ist für andere Routermodelle und Hersteller bestimmt und erklärt unspezifisch die Schritte zur Problemlösung.

  1. Öffne die Routereinstellungen. Meist unter https://192.168.178.1 oder http://speedport.ip bei Telekom Routern.

  2. Suche nach Einstellungen wie Firewall, Portfreigabe oder ähnliches.

  3. Füge eine neue Portfreigabe für die Switch hinzu. Hierbei musst du eventuell die IP-Adresse der Switch angeben, die du in den Switch Systemeinstellungen unter Internet findest.

  4. Wähle als Protokoll UDP aus.

  5. Wähle als freizugebene Ports den Bereich von 1 bis 65535 aus.
    Sollte dein Router keinen (so großen) Bereich zulassen suche nach der Option Exposed Host bzw. einer Option um alle Ports zu öffnen. Achte dabei aber darauf, dass die Switch dann komplett nach außen sichtbar ist. Du solltest diese Option nur während des Online Spiels aktiviert lassen und danach wieder deaktivieren.

  6. Speichere die Einstellungen.

  7. Führe einen Verbindungstest auf der Switch aus. Du solltest jetzt einen besseren NAT-Typ erhalten.

Ich hoffe die Anleitung hat dir geholfen. Wenn nicht, schreib mich gerne im Discord (AirAir#0148) oder hier im Forum an.

FinnhirnregenRiverSong1306NMHLianAlex_

Kommentare

  • @Connector Danke für Deine Anleitung! :)

    Bei meiner Switch zeigt es beim Verbindungstest NAT-Typ A an. Hatte am Sonntag schon eine andere Insel besucht und es gab keine Probleme. Heute kam allerdings der Fehlercode 2306-0502. Neustart der Konsole hat nicht geholfen, habe es auch mehrfach versucht aber ich konnte nicht verreisen. Allerdings konnte ich immerhin besucht werden.

    Hat noch jemand dieses Problem, bzw. kann es sein, dass es temporär ist und wenn ja, was habt ihr gemacht? Laut Nintendo funktionieren die Server ordnungsgemäß.

  • Ich hab den Test auch mal gemacht, da @Primrose die Probleme mit mir hatte~ und ich habe tatsächlich Nat Typ B hatte aber heute auch zum ersten mal probleme. Einmal mit Primrose das sie nicht zu mir konnte und einmal mit einer Person zum Rübentauschen das ich nicht zu ihr konnte, wo aber viele Probleme hatten.

    Kann allerdings das oben nicht machen, weil er net so viele Ports zulässt und keine Option gibt um alle Ports zuzulassen und da es bei meinen Freunden klappt besucht zu werden und zu besuchen, werd ich das erstmal so lassen xx.

  • @Finn aber das lag heute NICHT an Deiner Verbindung. :) Als das Spiel die Verbindung zum Internet herstellen wollte, hat es ewig genudelt und dann kam der Fehlercode. Ich hatte Deinen Dodo Code noch gar nicht eingegeben. Soweit bin ich erst gar nicht gekommen. ;)

    Finn
  • @Finn welchen Router benutzt du?
    @Primrose Ist die WLAN Verbindung zu deiner Switch stark genug?

  • o2 Homebox 6741

  • @Finn wie groß ist der maximale Bereich den du eintragen kannst?

  • @Connector Ja ich denke schon. Sie hat eigentlich immer volle Signalstärke und ist auch nicht so weit weg vom Router. Habe heute auf Twitter gelesen, dass die Verbindungsprobleme angeblich mit dem kleinen Update von Nintendo heute behoben sein sollen. Habe seit gestern aber nicht mehr ausprobiert jemanden zu besuchen aber das wird sich sicherlich in den nächsten Tagen wieder ergeben. Falls es dann auch nicht geht, starte ich mal den Router mal neu. Vielleicht hängt es da irgendwo.

  • Da kommt die Meldung
    "Bitte nutzen sie keinen der folgenden Ports: UDP 5060, TCP 7170."

  • Na toll. UDP 5060 ist nötig für dein VoIP-Telefon, sonst kommen nämlich keine Anrufe mehr an.

  • nya das wäre an sich kein Problem, da ich kein Haustelefon habe~

  • @Finn kannst du dann einfach den bei 1 Portbereich den Bereich 1 bis 5059 und bei 2 Portbereich den Bereich 5061 bis 65535 setzen?

  • bearbeitet, 27. März

    Nope hatte ich schon versucht, kommt der gleiche Fehler~

    Wobei wie gesagt, ich hab halt kaum Probleme, den einen Tag, dass war das erste mal und nun da ich ziemlich viel Geld mit Rüben gemacht habe, werd ich sowieso nicht mehr so viel Zeitreisen da ich später, wenn ich wieder die meiste Zeit in der WG bin mit den Hotspot vermutlich eh net Reisen kann~.
    Da lass ich lieber alles so wie es ist, bevor ich noch iwas falsch mache ^^''
    Aber dennoch danke~

  • Bringt alles nichts
    Bei mir bleibt es bei NAT Typ D
    Und die portfreigabe funktioniert bei mir auch nicht

  • Ich sitze leider auch bei Type D fest T.T

  • Bei mir bleibt es auch bei Typ D

  • @smk @magicblue @SpagettiFisch
    Wenn ihr das in diesem Thread postet, weil ihr um Unterstützung bei eurem Problem bitten wollt, müsstet ihr schon nähere Details nennen, damit wir wenigstens versuchen können, das Problem zu lösen. Was genau funktioniert nicht? Um welchen Router geht es? Was habt ihr bereits versucht, um das Problem zu beheben?

  • Hallo ihr beiden,

    ohne jegliche Informationen zur Lage und der einzigen Aussage „funktioniert nicht“ wird es schwierig der Sache auf dem Grund zu gehen. Vielleicht könnt ihr ein paar Informationen ergänzen, um etwaige Fehler oder Probleme zu identifizieren.

    Am besten helfen solche Informationen:

    • was für ein Router wird verwendet?
    • auf welcher Version ist die Software des Routers?
    • welche Lösungswege habt ihr ausprobiert und welche haben nicht funktioniert?

    Allgemein gilt im Übrigen: Der Vodafone Gigacube ist nicht dafür geeignet, da dort eine private statt einer öffentlichen IP Adresse verwendet wird. Somit ist es nicht möglich auf den NAT Typ A zu kommen.

    Luna
  • bearbeitet, 22. November

    Ich habe eine FritzBox mit FritzOS 7.21 und ich habe bereits manuelle Portfreigaben (das ist aber zu aufwendig), Selbstständige Portfreigaben und Exposed Host versucht und es ist trotzdem bei NAT Typ D geblieben.

    Um genau zu sein eine FritzBox 7490

  • bearbeitet, 24. November

    @SpagettiFisch
    Einzige Idee, die ich noch habe: Versuch mal den Teredo Filter zu deaktivieren.
    Dazu musst du im Menü wie folgt vorgehen:
    Kategorie „Internet“ > Menü „Filter“ > Reiter „Listen“ und anschließend runter scrollen bis „Teredo Filter aktivieren“ - dort den Haken entfernen und übernehmen.

    Anschließend einfach nochmal einen Test durchführen und schauen, welchen NAT Typ du hast.

    Falls irgendwas vom Menü nicht sichtbar ist, müsstest du vorher noch die erweiterte Ansicht aktivieren (linke Spalte ganz unten „Ansicht: Standard -> „Ansicht: Erweitert“).

    LianLuna
  • Ich glaube das habe ich auch schon mal probiert, aber ich kann ja noch mal kucken.